Recent Posts

Pages: 1 [2] 3 4 ... 10
11
General Discussions / Re: 3D Printer Projects
« Last post by Dragon on June 15, 2020, 23:36:55 »
HeroScape Marro Drones: https://www.thingiverse.com/thing:4366551 (I have the game but one of the figures was lost. Plus, they have a neat ability that could work with another set of these guys.)
Dungeon Doors: https://www.myminifactory.com/object/3d-print-dungeon-doors-84321 (Maybe a cool replacement for the cardboard doors in the HeroQuest game.)
12
Another thing that might be helpful if you're trying to upload to Google Photo with drag-and-drop onto an album page... you can drag a folder onto it to upload the whole folder, but it doesn't seem to pick up anything more than one level deep. Also, you can't just upload a zip file there. You could onto Google Drive, but not Google Photos. If you have a bunch of zip files that were created for storing a photos from a single directory, you might want to extract them all into the same folder. If they are in multiple levels of directories, and you're confident that you don't have duplicate filenames for what are actually different photos, you could run a command like this to grab all the readable files from 2 levels down or more and put it up on the current directory:

Code: [Select]
find ./ -mindepth 2 -readable -type f -exec mv {} ./ \;
Want to try this out with a prompt, try the ok option to be asked for each file:

Code: [Select]
find ./ -mindepth 2 -readable -type f -ok mv {} ./ \;
13
Table-top Games / Re: Board Game Calendar Weekly Challenges
« Last post by Dragon on June 15, 2020, 19:42:30 »
Who's up for the next weekly challenge? Did anyone complete last week's?

Week 25 - Play a game that you think you will win.

Personally, I have a lot of games in my collection that I could play to complete that challenge, but I'll list a few that wouldn't work for me - meaning, I think there is a better chance of me losing than winning. A few that come to mind are Acquire, which we played just last night and I had the worst score, Agricola, which we played for a few weekends in a row and I only won once, and Boggle, which I probably spend as much time looking up words during scoring to verify whether they are actually words as I do writing them down.
14
In the process of moving photos from one location to another, especially uploading to Google Photos, I've come across some corrupt video files. Lots of times we have videos of things that could have been photos, but not to digress from my purpose of this post, I found a nice little way to extract photos from some AVI files even though Google isn't able to upload the file in video format. In these cases, I had some videos which were able to play a little after opening the file locally, but would error out before getting to the end.

This is for use in Linux. This command will take MVI_1271.AVI, extract an image every 1 second and store it in a file called MVI_1271-01.jpeg, then MVI_1271-02.jpeg, MVI_1271-03.jpeg, and so on. Just replace MVI_1271.AVI with the video file you have, and the destination at the end of the line. Also, %2d at the end will form 2-digit suffixes while %3d will form 3-digit suffixes on your extracted image files.

Code: [Select]
ffmpeg -i MVI_1271.AVI -r 1 -f image2 MVI_1271-%2d.jpeg
I didn't have ffmpeg installed to start with, but it was simple to install it:

Code: [Select]
sudo apt install ffmpeg
15
Blogs / Install new fonts in Ubuntu / Bash + Desktop App file
« Last post by Dragon on June 13, 2020, 23:43:00 »
Apparently my Blog space here has become more of a list of Ubuntu/Linux tips and tricks. Probably mostly for me to reference in the future more than anything, but I'm sure other people might find this useful and interesting.

Anyway, this evening I was looking to install some new fonts into my machine. I tried GNOME Font Viewer, which was supposed to give the ability to install new fonts in addition to previewing existing ones. The main thing I wanted to do was get the files into the right place. Unfortunately, although GNOME Font Viewer, did the viewing part just find, installation options were no where to be seen. Drag-and-drop onto it didn't work... and other reviews complained about that feature not working anymore either, so I went out to search for a simple command line method.

I found a method on https://www.unixtutorial.org/how-to-install-ttf-fonts-in-linux/ which worked easily enough. Then I decided to make a Bash script out of it. Then I wanted to make it so I could just double-click an icon on my desktop and run it. Well... now I have all that working. Here's how it goes.

My Bash script, install-fonts.sh was created. This file will be saved in my home directory. I was using echo to display the messages in the terminal, but after creating the Desktop file to run with, I decided to use notify-send for pop-up messages on the desktop. This way works with both, and depending on which option is used on the Desktop file, the option to view the terminal could set to either true or false depending on preferences since it's not necessary.

Filename: install-fonts.sh
Permissions: 751
Code: [Select]
#!/bin/bash
MSG="Installing fonts from Downloads:"
echo "$MSG"
notify-send "$MSG"
MSG=`ls ~/Downloads/*.ttf`
echo "$MSG"
notify-send "$MSG"
cp ~/Downloads/*.ttf ~/.local/share/fonts/
fc-cache -f
MSG="Installation complete."
echo "$MSG"
notify-send "$MSG"

The second file needed is the Desktop file, install-fonts.desktop.
Filename: install-fonts.desktop
Permissions: 751
Code: [Select]
[Desktop Entry]
Name=Install Fonts
Comment=Install new fonts from Downloads
Exec=/home/dragon/install-fonts.sh
Terminal=false
Type=Application
The first time that you double-click this icon, you'll probably get a warning prompt that says "Untrusted application launcher" with two buttons, "Cancel" and "Trust and Launch". If you only get a Cancel button, you probably haven't added execute privileges to the Desktop file. That can be done by right-clicking, selecting Permissions, and the check the box to Execute: Allow executing file as program... or you could run "chmod +x install-fonts.desktop" in your terminal.

If you want to see the script run in the terminal when you double-click this Desktop file, simply change that "Terminal=false" line to "Terminal=true". Also, if you want to change the icon to an image of your own, simply add something like "Icon=/home/username/image.png" to this Desktop file. Otherwise, it will use whatever the default is for the system.

There's another issue that you might see if you're trying to use a relative path to your home directory also. Write out the path instead of using the tilde (~). It works fine in the Bash script, but not in the Desktop file.
16
General Discussions / Re: 3D Printer Projects
« Last post by Dragon on June 13, 2020, 10:21:03 »
17
Table-top Games / Board Game Calendar Weekly Challenges
« Last post by Dragon on June 10, 2020, 21:00:34 »
My wife bought a calendar for me from BoardGameTables.com, which is a pretty cool weekly calendar with a challenge listed for each week.

Week 1 - Play a game you received for Christmas. [✓] We played EcoSystem.
Week 2 - Play a game without talking.
Week 3 - Play a game with someone new.
Week 4 - Play one more game after you think it's time to go to bed.
Week 5 - Play an old game with a new strategy.
Week 6 - Play a game halfway through, then switch sides.
Week 7 - Play a game that has no luck.
Week 8 - Play a game with your neighbors.
Week 9 - Play a dexterity game with your non-dominant hand.
Week 10 - Play a card game.
Week 11 - Play the game you have owned the longest.
Week 12 - Play a game counter-clockwise instead of clockwise.
Week 13 - Play a game that you think you will lose.
Week 14 - Play a game with a lot of dice.
Week 15 - Play the game you own with the longest name.
Week 16 - Play a game in the Top Ten on BoardGameGeek.
Week 17 - Play a game without reading or knowing the rules.
Week 18 - Play a game three times: back to back to back.
Week 19 - Play a cooperative game. [✓] We played Hanabi.
Week 20 - Play the game you own with the shortest name. [✓] We played QE.
Week 21 - Play a game ranked outside of the Top 100 on BoardGameGeek. [✓] We played Hounded.
Week 22 - Play a game you bought at a thrift store. [✓] We played Othello.
Week 23 - Play a game that takes four hours or longer.
Week 24 - Play a game with at least eight players.

Are you able to complete the weekly challenge?

By the way, if you want to play the 2/3 guessing game for a chance to win a free game from them, go to https://boardgametablesdotcom.typeform.com/to/KvUczO today.
18
Conquest Of The Empire Online / Option - 3 day time limit
« Last post by Dragon on June 10, 2020, 16:56:20 »
Years ago I had a feature in the Conquest Online game that would skip to the next player after 3 days. I don't know why it was removed, but I'm thinking that I should bring it back. For those of you playing Conquest Online, do you think it would be a good option to have as something that can be selected at the start of the game?
19
Conquest Of The Empire Online / Bug - ship movement cut short
« Last post by Dragon on June 09, 2020, 07:24:42 »
Bug report: Problem with ship movement. Ship was not able to move after just one space. Checking the db records, the previous location is the same as the current location. May have been an issue with double-clicking or long loading page. A similar issue affected units before that were moving on land, but I believe that had been corrected. 

To players: Until this bug is fixed, if this issue is noticed on your turn, please wait on making any further actions in your turn temporarily and notify me to make adjustments to the record.

 
20
Conquest Of The Empire Online / Conquest Online - Starting a new game
« Last post by Dragon on June 06, 2020, 22:21:01 »
I know I need to update the process for starting a new game. It was one of those things I was being clever with long ago in order to keep spammers from getting into games. The trick is, you have to add people to your Buddies List in order to create a game with them. So, currently, they have to be members on the forum and the person starting the game must have at least posted a few times on the forum in order to get out of the new member restrictions that keep you from editing your profile and adding Buddies. 

After you have them added, go to the Setup page and you should see your Buddies in the list on the left side of the page -
http://www.dragonshobbies.com/games/cote/setup.php
Pages: 1 [2] 3 4 ... 10